Linux Install Troubleshoot

Written by Edwin Vigneau.

The following are instructions to run the linux versions on certain linux distributions in which they do not run out of the box.
All commands are to be entered in a terminal.

A 64-bit linux distribution is required.

Debian 9 (“Stretch”)

libssl1.0.0 is missing and it is not in the repositories. Install it from the “Jessie” repositories or download it from

Fedora 27

openal is missing, install it with:
su -c ‘dnf install openal-soft.x86_64’

libGLU is missing, install it with:
su -c ‘dnf install mesa-libGLU.x86_64’

libssl1.0.0 and are missing, but they are not in the repositories or even available as a package. We need to compile them from the source code.

If you don’t have gcc, install it with:
su -c ‘dnf install gcc’

Download the source code from:

Extract the archive

Open a terminal in the extracted directory

compile it with:
./config shared

Move the compiled libraries to their proper place with:
sudo cp /lib64/
sudo cp /lib64/

The game should run now.


If your distribution is not mentioned here and the game does not run, start the game from a terminal.
If there are missing libraries, their name will be shown so that you can install them.
They may not be in your distribution’s repositories however, since some are quite outdated.
You may have to compile them from source.